Accubid Anywhere Licensing

Incident Report for Trimble MEP Cloud

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 13:17 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 26, 2025 - 12:59 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 26, 2025 - 12:49 EST

Investigating

Thank you for contacting support. We are aware of an issue that appears to be affecting licensing. We understand the urgency this creates and want you to know that this is our absolute highest priority; our teams are actively investigating. We will provide an update as soon as we have confirmed information.
Posted Nov 26, 2025 - 12:39 EST
This incident affected: Accubid Anywhere (MEP Licensing).