Temporary Trade Service Temporary Degradation

Incident Report for Trimble MEP Cloud

Resolved

The issue with your Trimble Trade Service product has been resolved.

As a reminder, you can always see the up-to-date status of all Trimble MEP products at https://www.trimblemep.cloud/.

We again apologize for the inconvenience.
Posted Jan 23, 2026 - 15:09 EST

Update

We are continuing to investigate this issue.
Posted Jan 23, 2026 - 14:52 EST

Investigating

Some users may be experiencing a temporary performance degradation or outage for your Trimble Trade Service product. Our engineering team is working hard to resolve the issue. Please monitor https://www.trimblemep.cloud/ for updates on availability.

We apologize for the inconvenience. We will notify you as soon as the issue has been resolved and access to your Trimble MEP product has been restored.
Posted Jan 23, 2026 - 14:40 EST
This incident affected: Trade Service (BOM).