Trimble MEP Service Disruption
Incident Report for Trimble MEP Cloud
Resolved
All of Trimble MEP products are fully resolved and operational.
Posted Jul 20, 2024 - 11:36 EDT
Update
The majority of Trimble MEP products are fully resolved and being monitored. We are continuing to work on WinEst and ContractMaster and will post further updates as soon as they are available.
Posted Jul 19, 2024 - 17:19 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2024 - 12:52 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 12:49 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 12:44 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 09:24 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 06:17 EDT
Identified
We are aware of widespread disruption to Trimble Services & Applications.

We are continuing to work with a 3rd Party vendor to patch impacted infrastructure and will post further updates here as soon as they become available.

Please accept our apologies for the operational impact this outage is having and rest assured our Engineers are working to resolve this matter and restore services as quickly as possible
Posted Jul 19, 2024 - 05:06 EDT
This incident affected: MEP Platform (Authentication, Authorization, Automator, Configuration, Cost Libraries, E2E Messenger Service, Feature Flags, License, License Portal, MEP Building Model Backend, MEP Building Model Service, MEP Company Settings, Summary, MEP Licensing - Portal, MEP Licensing, MEP Online Help Backend, MEP Online Help Frontend, MEP Placement, MEP Placement Rules, MEP Platform - Portal, MEP Properties, MEP SignalR, Report Service - Gate, Report Service - Backend, Snowflake Contributor, TWINE Portal, Units, Work Breakdowns), Accubid Anywhere (Application), SysQue (Building Data, Duct Fabrication, Electrical, Fittings, License, NextGen Content, Project Info, Rev Info, Spooling, Supports), ProDesign (Electrical Calculation Backend, Graph Backend, Graph Cost, Graph Service), vPricer (vPricer Service), Ventilation Concept (Ventilation Concept EU), MEPcontent (MEPcontent Website), Analytics (TBC Analytics - Portal), LiveCount EU (ConversionConsoleService, ConversionService), Estimation MEP (NA) (Closeout, Drawing, MantaEmail, McaaWeblem), Estimation MEP (EU) (Closeout, Drawing, Inventory, PriceUpdate, Takeoff), and MEP SupportOps - Portal.